Actualización de la clase Redsys, cambia sha1 por sha256

Hola a todos, hace poco me entere que Redsys cambiaba la forma como firmaba sus datos pasando de sha1 a sha256, cambiando la forma de como enviar los datos por el input, así que con la documentación en la mano, el ejemplo que trae y la ayuda de muchos he actualizado la clase a una versión DEV para ir probando, corrigiendo y actualizando hasta obtener una versión estable.
Dejo aquí la url de la versión DEV.


https://github.com/ssheduardo/sermepa/tree/develop

Actualización:

Ya tenemos una versión estable, soportando los nuevos requerimientos del banco, se han realizado muchos cambios internamente como el soporte PSR-4, nombre de los métodos en ingles, ejemplo de como integrarlo en tus proyectos.

https://github.com/ssheduardo/sermepa

 

 

Facebooktwittergoogle_plusredditpinterestlinkedin

admin

admin escribió 90 entradas

Navegación de la entrada


Comentarios

  • Alfredo

    Buenas:

    He aplicado tu algoritmo con los datos de mi TPV que es un TPV de Caja Rural Asturias Redsys ya que nos mandan migrar de SHA1 a SHA256 y me pareció util tu código.

    El caso es que no me funciona con el FUC, terminal y la nueva clave generada en canales SHA256. Me dice
    No se puede realizar la operación
    Error en datos enviados. Contacte con su comercio.
    El codigo de error es el (que casualmente no aperece la guía)

    ¿a que puede ser debido?

    La URL que usaba con el viejo SHA1 era https://tpv01.cajarural.com/nuevo_tpv/tpv/jsp/tpvjp_validaComercio.jsp
    Ahora por lo que veo en tu codigo estas usando https://sis.redsys.es/sis/realizarPago

    Pero vamos que no me va ni con una ni con otra, la verdad que estoy desesperado porque nose que puede ser. EL panel de control de Redsys tengo configurado que pase parametros por URL

    Gracias.
    Saludos

  • Angel

    Hola buenas Eduardo ,

    Lo primero es darte las gracias por la clase de pasarela.

    Algunas veces es tedioso implementar una pasarela de pago.La verdad es que estuve utilizando la tuya hace algún tiempo para un desarrollo , pero al igual que al compañero de arriba veo que no funciona la ultima versión.

    He de aclarar que yo estoy utilizando unos datos de prueba para utilizar la clase y que estos datos son los que se suponía que daban para las pruebas, ya que el actual cliente del desarrollo todavía no tiene los datos proporcionados por su banco.

    El resto de datos me los he inventado y puede ser que alguno de los datos de prueba ya no sea valido y el problema esté ahí.

    Esperaré a que el cliente me proporcione los datos que les de el banco y os comento.

    Un saludo.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

Puede usar las siguientes etiquetas y atributos HTML:

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>